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1 The Experiment
This experiment presents the construction and operation of X-ray CCD (Charged-
Coupled Device) detector devices. In addition, the data recorded with CCDs (images
and spectra) are examined. CCDs are not only widely used in astronomy today, also
consumer cameras make use of CCD technology. CCDs are used in science wherever
electromagnetic radiation in the optical, ultraviolet or X-ray range or even charged par-
ticles have to be detected. CCDs are photo-sensitive semiconducting electronic detectors
with a very high light sensitivity and a fast readout capability. In addition to the char-
acteristics of the detector technology, the data analysis of raw data from CCDs will be
discussed. Many physical processes that are relevant for the CCD can be observed and
examined in this course.
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Figure 1: The eROSITA pn-CCD lab setup at the IAAT.

The exercises you will find in this guide are part of the course and are expected to be
discussed in the protocol as well.
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The course is completely recorded on video and split into 6 Chapters. The Chapters are:

1 Introduction: Overview of the Lab and the camera

2 Chapter 1: eROSITA: Introduction to the eROSITA mission

3 Chapter 2: The Camera: Theory of the camera and the CCD detector

4 Chapter 3: Data Processing: Theory of the Data Processing and Error Correction

5 Chapter 4: Camera Operation: The camera in action, online monitoring

6 Chapter 5: The Conclusion: The protocol and the offline analysis

You can access the videos via the ILIAS system of the University, on the Laptop in the
directory: /home/astro/Praktikum/Videos just by clicking the left mouse button on the
appropriate file, see also Chapter 5 of this document, or under the link: http://astro.uni-
tuebingen.de/seminars/praktikum/Praktikum_CCD-Versuch/Videos/videos.shtml.

2 Theory
Exercise 1: Use Wien’s law to estimate the temperature of a gas that emits

X-ray photons with an energy of 1 keV.

Exercise 2: Which interaction processes between radiation and matter are
possible?

Exercise 3: Get an overview of the common used detector types in the X-ray
range.

Exercise 4: Calculate with the help of the above information how many
electrons are generated in silicon during the absorption of an X-ray
photon with an energy of 6 keV.

Exercise 5: Why is the striped pattern of the “out of time events” observed
in both the readout direction and the opposite?

Exercise 6: What is the particle density in the measurement setup at
an operating temperature of −100 °C and a pressure of 10−6 mbar?
Assume that the ideal gas law is valid under these conditions.
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3 Measurement
In the lab, measurements are carried out with a radioactive 55Fe-source. 55Fe decays
via electron capture into an excited manganese core. In addition to the emission of an
Auger electron (60 % probability), the manganese core is deexcited via a Mn Kα line
(24.4 % probability, 5.889 keV) or via a Mn Kβ line (2.85 % probability, 6.49 keV):

55
26Fe −→ 55

25Mn∗ −→ 55
25Mn + γ (1)

The 55Fe-source is located behind a shutter on the left end of the measurement setup
as shown in Figure 1. The shutter is connected to a rotary manipulator and can thus
release or shield the source.

Exercise 7: Try to record some MIPs over several minutes, similar to Figure 2.

Figure 2: MIP traces accumulated over 20 minutes.

Exercise 8: Record a dark image for operation in full-frame mode, from
which you later can generate an offset map. In order to determine
statistical fluctuations, the images consist of approx. 200 individual
images. Save the measurement data in a file (→ darkframe.frms6).

Exercise 9: Look at the signals on the oscilloscope (compare Figure 3) when
the iron source is open and compare this with the setting when the
iron source is shutted.
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Figure 3: CAMEX signals on the oscilloscope during Fullframe Operation during expo-
sure of the source

Exercise 10: Perform a measurement in full-frame mode consisting of approx.
1000 images. Save the measurement data in a file (→ framelist.frms6).

4 Processing
The aim of the offline analysis is to correct and interpret the files “darkframe.frms6” and
“framelist.frms6” recorded in chapter 3. The file “darkframe.frms6” (without source) is
used to generate an offset and noise map to correct the data of the actual measurement
(with source), “framelist.frms6”. The analysis starts with so-called Framelists, such as
“darkframe.frms6” and “framelist.frms6”. Frame lists contain an energy value entry in
ADU for each of the pixels (65 536) of each frame. At the end of the analysis there is a
so-called “Eventlist”. The Eventlist contains only entries of actual “photon events”, i.e.
of real events triggered by an X-ray photon. Pixels not hit, which are in the majority,
no longer appear in the Eventlist. The energy calibrated Eventlist contains the line
spectrum of the source in energy units of “eV”.

The generation of Eventlists from frame data (Framelists) is the task of the onboard
electronics on satellites and is usually carried out by a frame processor. Reducing the
data to Eventlists already on board of the satellite reduces the required data transfer
rate to the ground station by a factor of 1000 (or more). The development of such frame
processors is part of the IAAT’s development activities in cooperations with national
and international partners.

The correction and interpretation of the measurement is carried out in several steps,
which are listed below and summarized in Figure 5 as a flow chart.

6



4.1 Data Conversion
The recorded data is available in “frame format”. Since all other programs work with
the FITS format, the data must first be converted to the FITS format. Use the software
“f62pfits”.

Exercise 11: Convert the Framelists from the ’frms6’ data format into a ’fits’
data format.

#f62pfits darkframe.frms6 darkframe.fits
#f62pfits framelist.frms6 framelist.fits

4.2 Display the Raw Data
The Framelist (framelist.fits) contains 1000 frames. We can use the ’FitsView’ software
(fv) in order to display the detector raw image of one single frame. Choose a frame
number (out of 1000 frames) and display the detector image.

Exercise 12: Display the detector image of one particular frame out of the
Framelist (framelist.fits) of 1000 frames. In this analysis we have chosen
frame number ’2’ of 1000 frames for display.

→ View the Framelist raw data with the FitsView (fv) software:
#fv framelist.fits → select frame number → Image

Exercise 13: Create a pulse height spectrum of any single frame of the
Framelist with the FitsView (fv) software. To extract such a spec-
trum from the Framelist of the 1000 measured frames use the command
“frame2tbl”. In this example the pulse height spectrum of frame num-
ber 2 is generated (→ square brackets [2] in the call below). You are
free to use any frame out of the 1000 frames you want, but best choose
the same frame number as in Exercise 12.

#frame2tbl framelist.fits[2] framelisttable_frame2.fits

→ Plot the pulse height spectrum with the FitsView (fv) software:
#fv framelisttable_frame2.fits → HIST x: PIXEL-PHA, y:-
→ Make
→ File → Print → Fit to Page → Print → File → ok =>
nameit.ps

Hint:
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You can convert the generated ps file into a pdf file by using the
Ghostview (gs) software:
#gs -sPAPERSIZE=a4 -q -dNOPAUSE -sDEVICE=pdfwrite -
sOutputFile=nameit.pdf nameit.ps -c quit

Hint:
For a correct scaling of the y-axis, you should switch the FitsView
(fv) software to “log” mode:
→ Edit → EditGraph... → Y-Axis; [X]Log → Apply

Most pixels have an offset value around 4000 ADU without being
exposed from the source.

4.3 Offset Map
First, an offset map is created from the unexposed images (darkframe.fits). To do this,
use the software “offset”. You can get the documentation of this and all subsequent
software by calling the software without any further parameters. In addition to the
offset map, the software generates a so-called “noise map”, which shows the fluctuation
around its offset value for each pixel. The software also writes a log file listing any MIP
hits.

Exercise 14: Create an offset and noise map with the “offset” software:

#offset darkframe.fits[1] offsetmap.fits noisemap.fits

→ Visualize the offset and the noise map by using the FitsView
(fv) software:
#fv offsetmap.fits → Image
#fv noisemap.fits → Image
Hint:
For a correct scaling of the y-axis, you should switch the FitsView
(fv) software to “linear” mode:
→ Edit → EditGraph... → Y-Axis; [X]Linear → Apply

4.4 Offset Correction
The offset map can now be subtracted from the measurement (Framelist) with the
command “calc”:

Exercise 15: Correct the offset with the command “calc”:
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#calc framelist.fits[1] m offsetmap.fits framelist_osub.fits

→ View the corrected Framelist data with the FitsView (fv) soft-
ware:
#fv framelist_osub.fits → select frame number → Image
Hint:
For a correct scaling of the y-axis, you should switch the FitsView
(fv) software to “linear” mode:
→ Edit → EditGraph... → Y-Axis; [X]Linear → Apply

Use FitsView (fv) to create the pulse height spectrum of the single
Framelist from exercise 13 after correction of the offset.
#frame2tbl framelist_osub.fits[2]

framelisttable_osub_frame2.fits

→ Plot the pulse height spectrum with the FitsView (fv) program:
#fv framelisttable_osub_frame2.fits → HIST x: PIXEL-PHA,
y:- → Make
→ File → Print → Fit to Page → Print → File → ok =>
nameit.ps

Hint:
For a correct scaling of the y-axis, you should switch the FitsView
(fv) software to “log” mode:
→ Edit → EditGraph... → Y-Axis; [X]Log → Apply

The pixels are now distributed around 0 ADU, the offset is cor-
rected!

4.5 Common Mode Correction
The common mode correction is done with the command “commode”.

Exercise 16: Correct the common mode with the command “commode”:

#commode framelist_osub.fits[1]
framelist_osub_commode.fits

→ View the Framelist data with the FitsView (fv) software:
#fv framelist_osub_commode.fits→ select frame number→ Image
Hint:
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For a correct scaling of the y-axis, you should switch the FitsView
(fv) software to “linear” mode:
→ Edit → EditGraph... → Y-Axis; [X]Linear → Apply

Use FitsView (fv) to create the pulse height spectrum of a sin-
gle frame of the Framelist from exercise 13 after correction of the
offset and the common mode. Compare the development of the
spectrum.

#frame2tbl framelist_osub_commode.fits[2]
framelisttable_osub_commode_frame2.fits

→ Plot the pulse height spectrum with the FitsView (fv) software:
#fv framelisttable_osub_commode_frame2.fits→ HIST x: PIXEL-
PHA, y:- → Make
→ File → Print → Fit to Page → Print → File → ok =>
nameit.ps

Hint:
For a correct scaling of the y-axis, you should switch the FitsView
(fv) software to “log” mode:
→ Edit → EditGraph... → Y-Axis; [X]Log → Apply

The pixels are now distributed even narrower around 0 ADU than
before. The common mode correction has corrected even more
pixels that were not hit by a photon to the value 0 ADU than
after the offset correction alone.

4.6 Event-Analyzer
Next apply the Event-Analyzer to the Framelist data. The Event-Analyzer software
“pattern” has an Eventlist as output that only contains the photon events out of the
1000 frames of the Framelist. The Eventlist consists of five columns: the image number
(frame), the column number (x), the row number (y), the energy value (PHA) in ADU
and the type of split events. For a more detailed analysis later on, the split event
distributions shown in Figure 4 are extended by the information which pixel has received
the largest part of the total energy.

This is the first time that only “events” are considered. Up to now, the pixels of complete
frames (256 × 256 pixels) (Framelists) were considered. From now on, only pixels that
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Figure 4: The type of the events shows how many pixels were hit and which pixel received
the largest part of the energy (highlighted in dark).

were actually hit by photons (so called photon events) will be viewed → Eventlist. The
1000 frames of the measurement (with source) are analyzed. The “pattern” command
implements the Event-Analyzer and records the hit pixels as events, it also takes split
events into account and combines neighboring pixels that have been hit and are above
the neighbor energy threshold as events. The Event-Analyzer uses the Noisemap as an
input to define the energy window threshold and the neighbor energy threshold for the
event analysis.

Exercise 17: Create an Eventlist taking into account the valid patterns with
the command “pattern”:
(#pattern <corrected frame list> <Noise-Map> <Output-File>

<lower energy> <upper energy> <confidence interval>)
#pattern framelist_osub_commode.fits[1] noisemap.fits

eventlist_osub_commode_pattern.fits 3000 11000 4

Use FitsView (fv) to create a first line spectrum from the Eventlist
that was created with the pattern analysis. Rough spectral lines
can already be assigned here, even if the energy is still specified
in ADU and not in eV.
#fv eventlist_osub_commode_pattern.fits

→ To generate a histogram of the Eventlist (incidence over ADU)
the standard FitsView (fv) Hist -function can not be used, be-
cause the Eventlist is not suitable for this.
However, a histogram can be generated using the extended func-
tion of FitsView (fv) under All .
→ All → Tools → Histogramm x: PHA; y: -; → Make

Hint:
For a correct scaling of the y-axis, you should switch the FitsView
(fv) software to “log” mode:
→ Edit → EditGraph... → Y-Axis; [X]Log → Apply

The histogram shows the incidence of counts over the energy
(ADU) ⇒ spectrum.
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4.7 CTE Determination
The Charge Transfer Efficiency (CTE) can be probed by using the Event-Analyzer. To
do this, you can create a histogram of the pulse height (PHA) over the row number (y-
axis) of the Eventlist -> see the instructions below. What do you see? The “pattern”
software (Event-Analyzer) has the CTE value as a parameter. Create a new Eventlist
with a CTE value other than 1 (CTE > 0.99). What does the histogram look like if you
use CTE = 0.99? How does it change if you increase it to CTE = 0.9999?

Exercise 18: Apply the Event-Analyzer software “pattern” and vary the
CTE value as input parameter.
(#pattern <corrected frame list> <Noise-Map> <Output-File>
<lower energy> <upper energy> <confidence interval> <CTE>)

#pattern framelist_osub_commode.fits[1] noisemap.fits
eventlist_osub_commode_pattern_cte0999.fits 3000

11000 4 0.999
#pattern framelist_osub_commode.fits[1] noisemap.fits

eventlist_osub_commode_pattern_cte09999.fits 3000
11000 4 0.9999

#pattern framelist_osub_commode.fits[1] noisemap.fits
eventlist_osub_commode_pattern_cte099995.fits 3000

11000 4 0.99995

Determine the CTE of the CCD by repeating the application of
“pattern” with different CTE values until the pulse height (PHA)
is constant over the row number (y-distance from the readout line)
of the CCD. The PHA change is plotted with FitsView (fv).

#fv eventlist_osub_commode_pattern_cte0999.fits→ HIST x:
y, y: PHA → Make
#fv eventlist_osub_commode_pattern_cte09999.fits → HIST
x: y, y: PHA → Make
#fv eventlist_osub_commode_pattern_cte099995.fits→ HIST
x: y, y: PHA → Make

The CTE correction is applied to the Framelist and creates a CTE
corrected Eventlist. The plot shows the energy of the Mn Kα / Kβ

lines along the row number (y). The CTE is correctly adjusted
when the lines are horizontal. When the CTE input value is too
small, the software is overcompensating and the correction is too
strong, resulting in a positive slope of the lines along the y-axis.
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4.8 Gain Determination
Each of the 2×128 channels of the CCD is preamplified on the chip and in the CAMEX.
However, this amplification is not absolutely identical for all channels due to the slightest
differences in the manufacture of the component and can vary from channel to channel
by up to 10 %. The gain determination is based on the selected X-ray line (in our case
the Mn Kα line). The ratio between the peak position of the line for a single channel and
the mean value of the peak positions gives a measure about which channel is amplified
stronger and which weaker.

Exercise 19: Use the FitsView (fv) software to plot the Mn Kα/Mn Kβ lines
along a row (256 pixels) in the x-direction. The different amplifications
of the 256 amplifier channels of the two CAMEXs become visible. The
jump in gain between pixels 127 and 128 is particularly noticeable,
representing the transition from one CAMEX chip to the other.

#fv eventlist_osub_commode_pattern_cte099995.fits→ HIST
x: x, y: PHA → Make

Exercise 20: Use the software “calcgain” to create the relative gain per CCD
column. The “calcgain” software creates a correction table (gain map)
containing the gain correction for each channel of the CCD.

(#calcgain <CTE corrected event list> <gainmap (output)>
<channel> <rows> <search interval>)

#calcgain eventlist_osub_commode_pattern_cte099995.fits[1]
gainmap.fits 0 255 1 254 6500 10000

→ View the gain map with the FitsView (fv) software:
#fv gainmap.fits → Image

Hint:
For a correct scaling of the y-axis, you should switch the FitsView
(fv) software to “linear” mode:
→ Edit → EditGraph... → Y-Axis; [X]Linear → Apply
Hint:
The gain differences between the channels are minimal. Use the
right mouse button and move the mouse over the FitsView plot
display. The gain differences will then become more easily visible.
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4.9 Gain Correction
The variation of the gain per readout channel distorts the signal and must be corrected.
For this purpose, the relative fluctuation of each channel amplification is recorded in the
gainmap and compensated by the “calc” software for all channels.

Exercise 21: Apply the gain correction to the original Framelist data. Use
the command “calc”.

(#calc <corrected frame list> <division> <gainmap>
<gain corrected Framelist (output)>)

#calc framelist_osub_commode.fits[1] d gainmap.fits[2]
framelist_osub_commode_gaincorrected.fits

→ View the gain corrected Framelist data with the FitsView (fv)
software:
#fv framelist_osub_commode_gaincorrected.fits→ choose a frame
number → Image
Hint:
For a correct scaling of the y-axis, you should switch the FitsView
(fv) software to “linear” mode:
→ Edit → EditGraph... → Y-Axis; [X]Linear → Apply

Create the spectrum of the single frame from exercise 13 after
correcting offset, common mode and gain.

#frame2tbl framelist_osub_commode_gaincorrected.fits[2]
framelisttable_osub_commode_gaincorrected_frame2.fits

→ Plot the pulse height spectrum with the FitsView (fv) software:
#fv framelisttable_osub_commode_gaincorrected_frame2.fits→
HIST
x: PIXEL-PHA, y:- → Make

Print the pulse height spectrum into a file with the FitsView (fv)
software:
→ File → Print → Fit to Page → Print → File → ok =>
nameit.ps
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4.10 Event-Analyzer
Run the Event-Analyzer on the gain corrected Framelist again. The Event-Analyzer
software “pattern” generates an Eventlist as output that only contains single photon
events from the Framelist. The Eventlist consists of five columns: the image number
(frame), the column number (x), the row number (y), the energy value (PHA) in ADU
and the type of split events. The Event-Analyzer uses the Noisemap as an input to
define the energy window threshold and the neighbor energy threshold for the event
analysis. Compare the Eventlist spectrum to the spectrum of Exercise 4.6 before gain
and CTE correction were applied.

Exercise 22: Create a new Eventlist with the gain-corrected data using the
“pattern” software.

(#pattern <Gain corrected frame list> <Noise map> <event
list (output)> <lower energy> <upper energy> <confidence

interval> <CTE value>)
#pattern framelist_osub_commode_gaincorrected.fits[1]

noisemap.fits
eventlist_osub_commode_gaincorrected_pattern_cte099995.fits

3000 11000 4 0.99995

Use FitsView (fv) to create a line spectrum from the Eventlist
created with the pattern analysis.
#fv eventlist_osub_commode_gaincorrected_pattern_cte099995.fits

→ To generate a histogram of the Eventlist (incidence over ADU)
the standard FitsView (fv) Hist -function can not be used, be-
cause the Eventlist is not suitable for this.
However, a histogram can be generated using the extended func-
tion of FitsView (fv) under All .
→ All → Tools → Histogramm x: PHA; y: -; → Make

Hint:
For a correct scaling of the y-axis, you should switch the FitsView
(fv) software to “log” mode:
→ Edit → EditGraph... → Y-Axis; [X]Log → Apply

The histogram shows the incidence of counts over the energy
(ADU) ⇒ spectrum.

Exercise 23: Create the line spectrum of the measurement with the software
“histo”.
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(#histo <Eventlist> <PHA spectrum (output)> <binning>)
#histo
eventlist_osub_commode_gaincorrected_pattern_cte099995.fits[1]

spectrum-adu.fits 25

→ Plot the spectrum with the FitsView (fv) software:
#fv spectrum-adu.fits → Plot x: PHA, y: counts → Plot

Hint:
For a correct scaling of the y-axis, you should switch the FitsView
(fv) software to “log” mode:
→ Edit → EditGraph... → Y-Axis; [X]Log → Apply

4.11 Energy Calibration
So far the energies of the photon events of the Eventlist are only known as ADU numbers.
Now we want to calibrate the ADU numbers to real physical energies of electron volts
(eV). This is done by the software “adu2ev”. The software make use of the fact, that the
energy of the Mn Kα/Mn Kβ lines is exactly known from laboratory experiments and
tabulated in literature. The software scans the data of the Eventlist for the Mn Kα/Mn
Kβ lines and calibrates the ADU scale on the x-axis of the spectrum into energy units
of eV.

Exercise 24: Create the energy calibrated spectrum of the measurement with
the software “adu2ev”.
(#adu2ev <ADU spectrum> <eV spectrum (output)> <search

interval of the k-alpha line in ADU>)
#adu2ev spectrum-adu.fits[1] spectrum-eV.fits 8400 9200

Create the energy calibrated line spectrum with FitsView (fv)
from the Eventlist that was just created with “adu2ev”. Identify
the emission lines in the spectrum.

→ Plot the spectrum with the FitsView (fv) software:
#fv spectrum-eV.fits → Plot x: energy, y: counts → Plot

Hint:
For a correct scaling of the y-axis, you should switch the FitsView
(fv) software to “log” mode:
→ Edit → EditGraph... → Y-Axis; [X]Log → Apply
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Label the visible spectral lines in the eV spectrum of the mea-
surement. Explain their origin and discuss the features in the
spectrum.
Hint:
The TextLabel function of FitsView can be used to label the spec-
tral lines:
→ Edit → Add TextLabel ...
Print the pulse height spectrum into a file with the FitsView soft-
ware:
→ File → Print → Fit to Page → Print → File → ok =>
nameit.ps

5 Protocol
For the Offline Data Processing we will borrow you a Laptop Computer. The Laptop
Computer runs the LINUX operation system and includes all necessary software needed
for data analysis as it is described step by step in this manual. The ’Username’ for the
Laptop Computer is ’astro’, the password is also ’astro’. You can produce all necessary
plots for the protocol on the Laptop Computer using the ’FitsView’ software (just type
’fv’ on the command line). Please return the Laptop Computer after you have submitted
the protocol to the institute again (IAAT, Sand 1, EG, Office A107)!

Please follow the guidelines for the Protocol handed out at the beginning of the Lab
Course! The Protocol should include at minimum:

• (A) An introduction into the purpose of the experiment

• (B) A brief chapter about the theory of CCDs including semiconductors, the setup
of the CCD, the interaction mechanism inside the CCD, the readout mechanism
...

• (C) The purpose of the step by step data corrections, discussion of the data cor-
rection (Offset/Common Mode/Gain ...)

• (D) The intermediate results (plots) of the data correction (Offset/Common Mode/
Gain...)

• (E) The final result, the spectrum of the 55Fe-source, a discussion of the spectrum

• (F) Concluding remarks to the experiment
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The Protocol should be in size between 10 and 50 pages. It must be your own work!.
We will not accept copy and paste text from other protocols, from the Course Manual,
from Wikipedia or from other sources. If you make use of pictures or figures from other
sources you must clearly reference their origin and their copyright holder!

We recommend clearly the ’LaTeX’ document writing system as the best tool to pro-
duce professional protocols, papers or any other scientific or technical documentation.
LaTeX is open source and free to download for any existing operating system! There is a
LaTeX template for the protocol also on the Laptop Computer. If you want to write the
protocol in LaTeX you can use this template and the LaTeX system already installed on
the Laptop Computer for this purpose. You will find the protocol template in the folder
’Praktikum/Protocol_LaTeX-Template’ on the Laptop Computer. Just start the File
Manager, navigate to the folder and double click the left mouse button on the file ’X-
ray-CCD.TEX’ This will start an Integrated Development Environment for the LaTeX
system. On the left side of the computer screen it will display the LaTeX source code
you can modify and edit for your purpose, on the right side of the computer screen you
can see the document results after compiling. The LaTeX compiler will finally produce
a ’pdf’-Document.

We accept protocols produced by any other document writing system also, as long as it
fulfills some certain criteria of scientific documents:

• Titel Page, Date of origin, Author, Group Number

• Paragraphs/Chapters

• Table of contend

• Numbered pages

• Numbered figures, tables or equations

• Figures with subtitels, tables with upper text

• References

Please return the Laptop Computer after you have submitted the protocol to the insti-
tute again (IAAT, Sand 1, EG, Office A107), thank you!
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Figure 5: Overview of the offline analysis steps and the software used.
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